import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=,)[a-zA-Z0-9]+(?= ?,)";
final String string = "convert(nvarchar(10),convert(datetime,VARIABLE02 , 121), 103)\n"
+ "convert(datetime,VARIABLE02 , 121) convert(datetime,VARIABLE02 , 121)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}