re = /(?<=,)[a-zA-Z0-9]+(?= ?,)/
str = 'convert(nvarchar(10),convert(datetime,VARIABLE02 , 121), 103)
convert(datetime,VARIABLE02 , 121) convert(datetime,VARIABLE02 , 121)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end