$re = '/(?<=,)[a-zA-Z0-9]+(?= ?,)/';
$str = 'convert(nvarchar(10),convert(datetime,VARIABLE02 , 121), 103)
convert(datetime,VARIABLE02 , 121) convert(datetime,VARIABLE02 , 121)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);