const regex = /great\s*(?!$)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('great\\s*(?!$)', 'mg')
const str = `whatagreatday
what a great day
I feel great`;
const subst = `great `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);