re = /great\s*(?!$)/m
str = 'whatagreatday
what a great day
I feel great'
subst = 'great '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result