$re = '/great\s*(?!$)/m';
$str = 'whatagreatday
what a great day
I feel great';
$subst = "great ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;