use strict;
my $str = 'Какой-то текст www.rambler.ru еще какой то текст <script src="www.google.com"> текст
перенос peter.ru текста и еще текст http://mail.com/dld/dd?sdld=dld ntrls sdlsdlds
slsalsf http://www.website.com sldsl
<script src=\'www.google.com\'> asdsd fsd f';
my $regex = qr/[^"]([0-9a-zа-я\.-]{2,}\.(?:ru|com|net)(?:\/[^\s]*)?)[^"]/iup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}