re = /[^"]([0-9a-zа-я\.-]{2,}\.(?:ru|com|net)(?:\/[^\s]*)?)[^"]/i
str = 'Какой-то текст www.rambler.ru еще какой то текст <script src="www.google.com"> текст
перенос peter.ru текста и еще текст http://mail.com/dld/dd?sdld=dld ntrls sdlsdlds
slsalsf http://www.website.com sldsl
<script src=\'www.google.com\'> asdsd fsd f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end