// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?iu)[^"]([0-9a-zа-я\.-]{2,}\.(?:ru|com|net)(?:\/[^\s]*)?)[^"]"#).unwrap();
let string = "Какой-то текст www.rambler.ru еще какой то текст <script src=\"www.google.com\"> текст
перенос peter.ru текста и еще текст http://mail.com/dld/dd?sdld=dld ntrls sdlsdlds
slsalsf http://www.website.com sldsl
<script src='www.google.com'> asdsd fsd f";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}