using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?<=<h1\s+class=['""]mb-0\s+mb-lg-1\s+svelte-jcq9ad['""]\s*>)(.*?)(?=</\s*h1)";
string input = @"<div>
<h1 class=""mb-0 mb-lg-1 svelte-jcq9ad"">AdBlock — best ad blocker</h1>
<h2 class=""mb-2 svelte-jcq9ad"">Block ads and pop-ups on YouTube, Facebook, Twitch, and your favorite websites.</h2>
</div>
</div>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}