re = /(?s)(?<=<h1\s+class=['""]mb-0\s+mb-lg-1\s+svelte-jcq9ad['""]\s*>)(.*?)(?=<\/\s*h1)/i
str = '<div>
<h1 class="mb-0 mb-lg-1 svelte-jcq9ad">AdBlock — best ad blocker</h1>
<h2 class="mb-2 svelte-jcq9ad">Block ads and pop-ups on YouTube, Facebook, Twitch, and your favorite websites.</h2>
</div>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end