package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(-\w+)\s*((?:=\S+)|"[^"]*")?`)
var str = `-arg1 -arg2 -arg3=500 -arg4=-250,200,50.0 -arg5 "Hello World" -arg6 "[I don't know whats going on /here/]"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}