re = /(-\w+)\s*((?:=\S+)|"[^"]*")?/
str = '-arg1 -arg2 -arg3=500 -arg4=-250,200,50.0 -arg5 "Hello World" -arg6 "[I don\'t know whats going on /here/]"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end