// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(-\w+)\s*((?:=\S+)|"[^"]*")?"#).unwrap();
let string = "-arg1 -arg2 -arg3=500 -arg4=-250,200,50.0 -arg5 \"Hello World\" -arg6 \"[I don't know whats going on /here/]\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}