$re = '/(Franklin,\s|franklin,\s)/';
$str = 'Franklin, can you please do this or this for me?
franklin, can you please do this or this for me?
Franklin, can you please remind me to do X at 0:00pm?
franklin, can you please remind me to do X at 0:00pm?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);