import re
regex = re.compile(r"(Franklin,\s|franklin,\s)")
test_str = ("Franklin, can you please do this or this for me?\n"
"franklin, can you please do this or this for me?\n\n"
"Franklin, can you please remind me to do X at 0:00pm?\n"
"franklin, can you please remind me to do X at 0:00pm?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")