import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(\\d)(?!\\1{2})){1,9}$|^(?:(\\d)(?!\\2{2})){10}\\d*$";
final String string = "1234567\n"
+ "1234456\n"
+ "1234445\n"
+ "12345678904444\n\n"
+ "1234567890\n"
+ "11234567890\n"
+ "11134567890\n"
+ "12345666890\n\n"
+ "81234567890\n"
+ "811234567890\n"
+ "811134567890\n"
+ "12345666890";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}