import re
regex = re.compile(r"^(?:(\d)(?!\1{2})){1,9}$|^(?:(\d)(?!\2{2})){10}\d*$", flags=re.MULTILINE)
test_str = ("1234567\n"
"1234456\n"
"1234445\n"
"12345678904444\n\n"
"1234567890\n"
"11234567890\n"
"11134567890\n"
"12345666890\n\n"
"81234567890\n"
"811234567890\n"
"811134567890\n"
"12345666890")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")