$re = '/^(?:(\d)(?!\1{2})){1,9}$|^(?:(\d)(?!\2{2})){10}\d*$/m';
$str = '1234567
1234456
1234445
12345678904444
1234567890
11234567890
11134567890
12345666890
81234567890
811234567890
811134567890
12345666890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);