package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*\[start\]|\[end\].*)(*SKIP)(*F)|a`)
var str = `Hello iam a [start] string and iam very happy with [end] beeing a string`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}