// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*\[start\]|\[end\].*)(*SKIP)(*F)|a").unwrap();
let string = "Hello iam a [start] string and iam very happy with [end] beeing a string";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}