$re = '/(.*\[start\]|\[end\].*)(*SKIP)(*F)|a/m';
$str = 'Hello iam a [start] string and iam very happy with [end] beeing a string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);