#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[0-9A-Za-z.@]+:[0-z]+"
Local $sString = "len.simms@talktalk.net:sophie1" & @CRLF & _
"Status: Premium" & @CRLF & _
"Storage available: 6 TB of 6 TB" & @CRLF & _
"Payout sum: $0.00" & @CRLF & _
"Bandwith available: 495.88 GB of 3 TB" & @CRLF & _
"E-mail: len.simms@talktalk.net" & @CRLF & _
"------------" & @CRLF & _
"tabbott85@hotmail.co.uk:jeneva" & @CRLF & _
"Status: Premium" & @CRLF & _
"Storage available: unlimited" & @CRLF & _
"Payout sum: $0.00" & @CRLF & _
"Bandwith available: 465.4 GB of 1 TB" & @CRLF & _
"E-mail: tabbott85@hotmail.co.uk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")