import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9A-Za-z.@]+:[0-z]+";
final String string = "len.simms@talktalk.net:sophie1\n"
+ "Status: Premium\n"
+ "Storage available: 6 TB of 6 TB\n"
+ "Payout sum: $0.00\n"
+ "Bandwith available: 495.88 GB of 3 TB\n"
+ "E-mail: len.simms@talktalk.net\n"
+ "------------\n"
+ "tabbott85@hotmail.co.uk:jeneva\n"
+ "Status: Premium\n"
+ "Storage available: unlimited\n"
+ "Payout sum: $0.00\n"
+ "Bandwith available: 465.4 GB of 1 TB\n"
+ "E-mail: tabbott85@hotmail.co.uk";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}