# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[0-9A-Za-z.@]+:[0-z]+"
test_str = ("len.simms@talktalk.net:sophie1\n"
"Status: Premium\n"
"Storage available: 6 TB of 6 TB\n"
"Payout sum: $0.00\n"
"Bandwith available: 495.88 GB of 3 TB\n"
"E-mail: len.simms@talktalk.net\n"
"------------\n"
"tabbott85@hotmail.co.uk:jeneva\n"
"Status: Premium\n"
"Storage available: unlimited\n"
"Payout sum: $0.00\n"
"Bandwith available: 465.4 GB of 1 TB\n"
"E-mail: tabbott85@hotmail.co.uk")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.