# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\(.*?\)|(\w+)//gm;t' <<< "Word1 Word2 word3 (some words in brackets)
Word1 (some words in brackets)
word1, Word2 (some words in brackets)"