import re
regex = re.compile(r"\(.*?\)|(\w+)", flags=re.MULTILINE)
test_str = ("Word1 Word2 word3 (some words in brackets)\n"
"Word1 (some words in brackets)\n"
"word1, Word2 (some words in brackets)")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)