#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\(.*?\)|(\w+)"
Local $sString = "Word1 Word2 word3 (some words in brackets)" & @CRLF & _
"Word1 (some words in brackets)" & @CRLF & _
"word1, Word2 (some words in brackets)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)