const regex = new RegExp('^\\D*(\\d+)\\h*((?:(?!\\h{2,}).)+)', '')
const str = ` 1 DOPPEL TYP I MEERBLICK HALBPENSION`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}