using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"asset_class_([^.]*)_color_.*";
string input = @"asset_class_flexible_color_name";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}