package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)asset_class_([^.]*)_color_.*`)
var str = `asset_class_flexible_color_name`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}