$re = '/asset_class_([^.]*)_color_.*/m';
$str = 'asset_class_flexible_color_name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);