using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0+([1-9]+[0-9]{0,})";
string input = @"000860
000860123
000800
000810
0008";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}