package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`0+([1-9]+[0-9]{0,})`)
var str = `000860
000860123
000800
000810
0008`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}