$re = '/0+([1-9]+[0-9]{0,})/';
$str = '000860
000860123
000800
000810
0008';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);