#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"title":\s*"([^"]*\bSword\b[^"]*)""
Local $sString = "" & @CRLF & _
" {" & @CRLF & _
" "store": {" & @CRLF & _
" "book": [" & @CRLF & _
" {" & @CRLF & _
" "category": "reference"," & @CRLF & _
" "author": "Nigel Rees"," & @CRLF & _
" "title": "Sayings of the Century"," & @CRLF & _
" "price": 8.95" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "category": "fiction"," & @CRLF & _
" "author": "Evelyn Waugh"," & @CRLF & _
" "title": "Sword of Honour"," & @CRLF & _
" "price": 12.99" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "category": "fiction"," & @CRLF & _
" "author": "Herman Melville"," & @CRLF & _
" "title": "Moby Dick"," & @CRLF & _
" "isbn": "0-553-21311-3"," & @CRLF & _
" "price": 8.99" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "category": "fiction"," & @CRLF & _
" "author": "J. R. R. Tolkien"," & @CRLF & _
" "title": "The Lord of the Rings"," & @CRLF & _
" "isbn": "0-395-19395-8"," & @CRLF & _
" "price": 22.99" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "bicycle": {" & @CRLF & _
" "color": "red"," & @CRLF & _
" "price": 19.95" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" "expensive": 10" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")