import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"title\":\\s*\"([^\"]*\\bSword\\b[^\"]*)\"";
final String string = "\n"
+ " {\n"
+ " \"store\": {\n"
+ " \"book\": [\n"
+ " {\n"
+ " \"category\": \"reference\",\n"
+ " \"author\": \"Nigel Rees\",\n"
+ " \"title\": \"Sayings of the Century\",\n"
+ " \"price\": 8.95\n"
+ " },\n"
+ " {\n"
+ " \"category\": \"fiction\",\n"
+ " \"author\": \"Evelyn Waugh\",\n"
+ " \"title\": \"Sword of Honour\",\n"
+ " \"price\": 12.99\n"
+ " },\n"
+ " {\n"
+ " \"category\": \"fiction\",\n"
+ " \"author\": \"Herman Melville\",\n"
+ " \"title\": \"Moby Dick\",\n"
+ " \"isbn\": \"0-553-21311-3\",\n"
+ " \"price\": 8.99\n"
+ " },\n"
+ " {\n"
+ " \"category\": \"fiction\",\n"
+ " \"author\": \"J. R. R. Tolkien\",\n"
+ " \"title\": \"The Lord of the Rings\",\n"
+ " \"isbn\": \"0-395-19395-8\",\n"
+ " \"price\": 22.99\n"
+ " }\n"
+ " ],\n"
+ " \"bicycle\": {\n"
+ " \"color\": \"red\",\n"
+ " \"price\": 19.95\n"
+ " }\n"
+ " },\n"
+ " \"expensive\": 10\n"
+ " }\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}