using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(edit|view)\:([0-9]+)";
string substitution = @"<a href=""$1.php?UPC=$2"">($1 Product)</a>";
string input = @"edit:4961310112967 - edit:021331612649 Are these correct?
edit:1231289389123
edit:123123lkajsdad
view:234234234234234";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}