$re = '/(edit|view)\:([0-9]+)/m';
$str = 'edit:4961310112967 - edit:021331612649 Are these correct?
edit:1231289389123
edit:123123lkajsdad
view:234234234234234';
$subst = "<a href=\"$1.php?UPC=$2\">($1 Product)</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;