use strict;
my $str = 'edit:4961310112967 - edit:021331612649 Are these correct?
edit:1231289389123
edit:123123lkajsdad
view:234234234234234';
my $regex = qr/(edit|view)\:([0-9]+)/mp;
my $subst = '<a href="$1.php?UPC=$2">($1 Product)</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";