using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"trig:seq:lev\s+([+-]?\d+)";
string input = @"trig:seq:lev -43
trig:seq:lev 43
trig:seq:lev +43
trig:seq:lev -43
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}