package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)trig:seq:lev\s+([+-]?\d+)`)
var str = `trig:seq:lev -43
trig:seq:lev 43
trig:seq:lev +43
trig:seq:lev -43
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}