re = /trig:seq:lev\s+([+-]?\d+)/m
str = 'trig:seq:lev -43
trig:seq:lev 43
trig:seq:lev +43
trig:seq:lev -43
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end