#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a\b(?=(?>[^>]*rel\s*=\s*[\"\']([^\"\']+))?)[^>]*href=\s*[\"\']\s*\K[^\"\']+"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do " & @CRLF & _
"eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut " & @CRLF & _
"enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi " & @CRLF & _
"ut aliquip ex ea commodo consequat. <a href="http://example.com" rel="nofollow">Duis</a>" & @CRLF & _
"nirure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat" & @CRLF & _
"nulla pariatur. Excepteur sint <a href="http://example2.com" rel="nofollow">Duis</a> occaecat cupidatat non proident, sunt in culpa qui" & @CRLF & _
"officia deserunt mollit anim id est laborum."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")