import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\b(?=(?>[^>]*rel\\s*=\\s*[\\\"\\']([^\\\"\\']+))?)[^>]*href=\\s*[\\\"\\']\\s*\\K[^\\\"\\']+";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do \n"
+ "eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut \n"
+ "enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi \n"
+ "ut aliquip ex ea commodo consequat. <a href=\"http://example.com\" rel=\"nofollow\">Duis</a>\n"
+ "nirure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat\n"
+ "nulla pariatur. Excepteur sint <a href=\"http://example2.com\" rel=\"nofollow\">Duis</a> occaecat cupidatat non proident, sunt in culpa qui\n"
+ "officia deserunt mollit anim id est laborum.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}