package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^ *D *E( *[A-Za-z0-9]){20} *$`)
var str = `DE21301204000000015228`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}