const regex = /^ *D *E( *[A-Za-z0-9]){20} *$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ *D *E( *[A-Za-z0-9]){20} *$', '')
const str = `DE21301204000000015228`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}