$re = '/^ *D *E( *[A-Za-z0-9]){20} *$/';
$str = 'DE21301204000000015228';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);