import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Loadcase -- \\d+\\s+(.+)\\s{6}";
final String string = "Loadcase -- 1 Dead + Roof Live Dur Factors: 1.15 1.15\n\n"
+ "Domain Type ------------Name------------ Dir plf-beg plf-end -x-beg-- -x-end-- -y-beg-- -y-end--\n\n"
+ "Top Dead TCDL Vert 14.00 14.00 -2-00-00 11-00-00 \n\n"
+ "Top Dead TCDL Vert 14.00 14.00 11-00-00 24-00-00 \n\n"
+ "Bottom Dead BCDL Vert 20.00 20.00 0 22-00-00 \n\n"
+ "Attic_BC Dead RoomDL_BC Vert 20.00 20.00 3-06-08 18-02-12 \n\n"
+ "Attic_TC Dead RoomDL_TC Vert 10.00 10.00 3-09-04 18-02-12 \n\n"
+ "Top RoofLive TCLL Vert 60.00 60.00 -2-00-00 11-00-00 \n\n"
+ "Top RoofLive TCLL Vert 60.00 60.00 11-00-00 24-00-00 \n\n"
+ "Domain Type ------------Name------------ Dir Lbs -x-loc-- -y-loc-- EQ plf EQ width\n\n"
+ "Bottom Dead SidewallDL Vert 49 3-05-03 07-05 24.5 24.0\n\n"
+ "Bottom Dead SidewallDL Vert 49 18-04-01 07-03 24.5 24.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}