use strict;
my $str = 'Loadcase -- 1 Dead + Roof Live Dur Factors: 1.15 1.15
Domain Type ------------Name------------ Dir plf-beg plf-end -x-beg-- -x-end-- -y-beg-- -y-end--
Top Dead TCDL Vert 14.00 14.00 -2-00-00 11-00-00
Top Dead TCDL Vert 14.00 14.00 11-00-00 24-00-00
Bottom Dead BCDL Vert 20.00 20.00 0 22-00-00
Attic_BC Dead RoomDL_BC Vert 20.00 20.00 3-06-08 18-02-12
Attic_TC Dead RoomDL_TC Vert 10.00 10.00 3-09-04 18-02-12
Top RoofLive TCLL Vert 60.00 60.00 -2-00-00 11-00-00
Top RoofLive TCLL Vert 60.00 60.00 11-00-00 24-00-00
Domain Type ------------Name------------ Dir Lbs -x-loc-- -y-loc-- EQ plf EQ width
Bottom Dead SidewallDL Vert 49 3-05-03 07-05 24.5 24.0
Bottom Dead SidewallDL Vert 49 18-04-01 07-03 24.5 24.0';
my $regex = qr/Loadcase -- \d+\s+(.+)\s{6}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}